Lion 10.7 on older MacBook Pro with Intel Core Duo ?

This is a discussion on Lion 10.7 on older MacBook Pro with Intel Core Duo ? within the Mac OS X forums, part of the Mac Software category; Hello, I found out that the Mac OS X 10.7 Lion need to have at least a Mac with an Intel Core 2 Duo processor... ...

Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Jul 2011
    Posts
    2
    Member #
    1693

    Lion 10.7 on older MacBook Pro with Intel Core Duo ?

    Hello,

    I found out that the Mac OS X 10.7 Lion need to have at least a Mac with an Intel Core 2 Duo processor... Mine (MacBook Pro 1.1 (older model)) has an 1.83 GHz Intel Core Duo, working on Mac OsX 10.6.8.
    Now I got confused: is the Intel Core 2 Duo the same as mine Intel Core Duo?

    Thanks for your help!
    Ciel

  2. Ads

    Posts
    Many

  3. #2
    Senior Member
    Join Date
    Jul 2011
    Posts
    356
    Member #
    112
    Liked
    5 times
    Ok, I could be wrong and happy for others to chime in here and correct me but I think Core Duo is 32bit and Core 2 Duo is 64bit architecture. My understanding, albeit limited is that Lion is designed for 64bit.

    See this link, it explains what works and what doesn't http://reviews.cnet.com/8301-13727_7-20080681-263/will-your-mac-run-os-x-10.7-lion/
    Last edited by Gabriel1; 07-30-2011 at 12:48 PM.
    The Archangel

  4. #3
    Super Moderator
    Join Date
    Jul 2011
    Location
    Michigan
    Posts
    421
    Member #
    11
    Liked
    3 times
    That's correct the Core Duo is a 32 bit micro architecture while the Core 2 Duo is a 64 bit mico architecture.

    Lion will not run on the older Core Duo systems. It will only run on the Core 2 Duo platformes.

    Sent from my DROIDX using Tapatalk
    "Guidelines of Conduct" for Appleforums.net
    Respect is number 1 in the Forums.

    Please be aware that some software is not compatible with Lion just yet. So if your planning on upgrading check to see if the software that you are using is compatible with Lion.

  5. #4
    Junior Member
    Join Date
    Jul 2011
    Posts
    7
    Member #
    749
    I only purchased this slightly older Macbook so I can create an iPhone app but now I can't even use Xcode because I need Lion for 4.1.
    Btw, its a 2008 macbook white with 1.8 core duo and 2gb ram. I might be open to upgrading the ram and cpu if possible.
    Last edited by Virtual; 07-31-2011 at 05:21 PM.

  6. #5
    Member
    Join Date
    Jul 2011
    Posts
    29
    Member #
    1623
    Unfortunately Intel Macs with Intel Core Duo can't run OSX Lion. I suffer too as I can't run OSX Lion on my old Mac Mini. Virtual, on every single Mac except the Air, it's possible to upgrade the RAM (just make sure to ground yourself immediately before touching it). however, you can't upgrade the CPU. About Xcode, I managed to programed apps for iOS 4.1 fine using Xcode 3. so did Apple change something. Also the 2008 model of the MacBook can run Lion unless you were talking about the first one which was launched in early 2006.
    Send from my jailbroken InterestingCompanionPad.
    first generation Apple Intel Mac Mini, jailbroken iPad first generation wifi 16gb.
    Came from iPad Forums

Remove Ads

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Replies: 10
    Last Post: 08-25-2011, 03:32 AM
  2. Replies: 1
    Last Post: 07-29-2011, 05:16 PM

Contact Us
Back to top